#1 2016-09-21 17:04:51

ravijordan
Guest

Answer to the "Audio" is undefined error when use an old IE version

Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\index.html"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\styles\default.css"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\styles\builder.css"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\app\styles\scaled.css"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\scripts\builder.js"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\app\scripts\app.js"

Error: "Expected identifier" - Line: 508 - Char: 8710 - Code: 0 - Url: [url]http://127.0.0.1:9999/builder/scripts/builder.js[/url]

Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\cordova.js"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\fonts\glyphicons-halflings-regular.eot"

Error: "'Audio' is undefined" - Line: 13 - Char: 3 - Code: 0 - Url: [url]http://127.0.0.1:9999/app/scripts/app.js[/url]

Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\fonts\videogular.eot"
Resolved "C:\Users\RAVI JORDAN\Documents\AppBuilder\Samples\Camera\Camera_Compiled\www\builder\fonts\fontawesome-webfont.eot"

not even the sample apps are running which are provided please help me out.

#2 2016-09-21 17:14:47

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,715
Website

Re: Answer to the "Audio" is undefined error when use an old IE version

Hello Ravi,

Upgrade your Internet Explorer version to the latest one. The error is more or less clear: the "Audio" object is not available in your Internet Explorer version. If you need any further help, please, don't hesitate to post in this forum.

Offline

#3 2018-01-08 17:56:44

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,715
Website

Re: Answer to the "Audio" is undefined error when use an old IE version

Hello to all,

Just to inform that the current DecSoft's App Builder fix this problem in the way that the Javascript Audio object is not required from the scratch, but, only for the Beep and the PlaySound actions. This give the apps a chance to work on Internet Explorer 10, even when it's very recommmended to upgrade, at least, to Internet Explorer 11, in which the Javascript Audio object is already available.

Offline

Board footer

Powered by FluxBB


Copyright ©2018 DecSoft. All rights reserved.