HTML Compiler: No support in compiler for Javascript ECMAScript 2015 (ES6) version?



Jan van den Hogen
Compiling Javascript goes rather OK for the ES5 distro, but everything I try to do in ES6 doesn't work properly. Is this a compiler thing, so JS support stops at ES5? I'm curious what your experiences are.

David Esperalta

Hello Jan,

I think it's an issue of Internet Explorer 11. HTML Compiler is based in Internet Explorer 11, so, we can't write code that are not supported by this browser.



Everybody can read the DecSoft's support forum for learning purposes, however only DecSoft's customers can post new threads. Purchase one or more licenses of some DecSoft's products in order to give this and other benefits.