#1 2016-02-06 08:57:20

codex
Member
From: BostonUSA
Registered: 2016-02-06
Posts: 1

{ISSUE} File browser and file selection

Hi,

I am following the tutorials as I am pretty new and I have to say you've done an amazing job with AppBuilder! But I have run into a few issues. Using v 2016.71 on Windows 10.

1.  When I debug a new app, in the tutorial you go to a preview window that already the address 127.0.0.1:9999/#/NewView1. Where is this in version 2016.71? The preview Window is always blank (white). I opened Chrome and entered 127.0.0.1:9999 but it's displaying an old app, not the one I am working on. How do I refresh Chrome to preview current app?


2. In most all browse File Windows, I can't go up any higher than the Windows Desktop folder level. I have multiple hard-drives and I can't browse to them.

appbuilderss1.jpg

3. App Options > Cordova > Splash ... I cant select either folder to browse directories at all!  Same with Interface > Icon > File Path.

appbuilderss2.jpg

Cheers!

Last edited by codex (2016-02-06 08:58:45)

Offline

#2 2016-02-06 10:37:03

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,661
Website

Re: {ISSUE} File browser and file selection

Hello codex,

Thanks for your interest and your kindly words. I want to answer you by reversing your question's order:

3º Maybe I need to indicate this in some way, but, the splash screen editbox buttons only works if you had previously saved the application. This is valid also for the application's icon, for example, and this is because the program try to establish this kind of stuff relative to the application and not using absolute paths. Then we can share the application or move it into another system without loss such paths.

2º Certainly you found a mistake with the "SelectDirectory" procedure, which is currently used in four program's places. I update App Builder right now and the mistake has been fixed in all the places where the "SelectDirectory" is used. Now the Desktop directory is the default one (when needed), but we also can navigate to others directories and drives. Thanks for the advise codex.

1º The debugger address are not changed, then, probably we have here some other issue. Remember that you no need to try it with an external browser (you can do it, of course, and can be very good) but you must view the application running in the debugger browser. My recomendation for now is delete your app's "_Compiled" directory and try to compile it again. If this fail, please, tell me codex.

Offline

Board footer

Powered by FluxBB


Copyright ©2018 DecSoft. All rights reserved.