#1 2017-02-16 17:38:30

svanneste
Member
From: Paris, France
Registered: 2015-05-27
Posts: 155

[SOLVED] Build 2017.11 - font awesome performance issue

Hello David,
I can't see all the icons. I tried to restart the computer and AB without success

awesome.png

Thanks

Last edited by svanneste (2017-02-16 18:58:28)

Offline

#2 2017-02-16 18:33:03

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello Samuel,

svanneste wrote:

Hello David,
I can't see all the icons. I tried to restart the computer and AB without success

https://www.davidesperalta.com/support/ … cfd3ef.png

Thanks

Yes; certainly some of the Awesome icons appear hidden here too. I am not sure what happend, since the appropiate Windows's API function to register the font appear to work as expected, that is, doesn't return any error. I must investigate this a bit Samuel and will inform here about. Sorry for the inconveniences!

P.S. As a tip... if you pass the cursor over the icons (even the hidden ones) their names appear in an small tip, and, in fact, that icons can be used in the application, that is, the problem is only related with the Icons' picker dialog.

Online

#3 2017-02-16 18:34:56

svanneste
Member
From: Paris, France
Registered: 2015-05-27
Posts: 155

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello David,
Thanks for the tip of the icons names. It will be very useful smile
Good luck for the investigation

Offline

#4 2017-02-16 18:56:09

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello Samuel,

It's done! I just forget something...

4R2LIzu.gif

Update your AB copy: this time you must do it manually!

Online

#5 2017-02-16 18:58:54

svanneste
Member
From: Paris, France
Registered: 2015-05-27
Posts: 155

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Well done! Thanks a lot Sir David big_smile

Offline

#6 2017-02-16 19:00:07

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello!

svanneste wrote:

Well done! Thanks a lot Sir David big_smile

You're welcome sir! smile

Online

#7 2017-02-16 21:47:14

tin
Member
Registered: 2016-03-20
Posts: 161

Re: [SOLVED] Build 2017.11 - font awesome performance issue

I still have the same problem David.I already try your download link.
So can you explain how to fix this font manually? (maybe it not fix for me because privileges access in my window user)

Offline

#8 2017-02-16 23:30:14

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello to all,

tin wrote:

I still have the same problem David.I already try your download link.
So can you explain how to fix this font manually? (maybe it not fix for me because privileges access in my window user)

Sorry te inconveniences tin. In fact we no need to install the fonts manually: App Builder register the fonts privatelly using the appropiate Windows' API. This can be done without require any special nor admin privileges.

Please, try this: close App Builder (if running) and uninstall the program from the Windows's control panel. Then download the latest App Builder release and install it normally.

If you continue having problems, please, tell me in order to try to help you.

Online

#9 2017-02-17 10:34:42

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hello to all,

I am very sorry. Certainly I leave a bug in the latest release, that causes the FontAwesome font can't be registered in the rigth way. Then please, tin, Samuel and others, upgrade your AB copies and let me know if the Icons' Picker dialog is working now or if some problem still occurring.

Again sorry any possible inconveniences guys!

Online

#10 2017-02-17 15:46:05

tin
Member
Registered: 2016-03-20
Posts: 161

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Problem solve now in 2017.12 version.Thanks David.

Offline

#11 2017-02-17 16:45:07

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,660
Website

Re: [SOLVED] Build 2017.11 - font awesome performance issue

Hi to all!

tin wrote:

Problem solve now in 2017.12 version.Thanks David.

You're welcome tin! smile

Online

Board footer

Powered by FluxBB


Copyright ©2018 DecSoft. All rights reserved.