#1 2015-07-09 12:20:51

impulsmedia
Member
Registered: 2015-04-21
Posts: 64

local/intranet installation of an app does not run under IE and CHROME

Hello,

something strange: I can start and show a compiled app with FIREFOX with simply open the index.html. If I do the same with IE or CHROME the app doesn´t start, I  get  a white screen and the app name isn´t yet read, means I see the {{App.Name}} as URL.
The IE console (F12)  says something about document mode 7 ... some APIs may be not available ...
Any idea what to do? Thanks in advance, Walter

Offline

#2 2015-07-09 15:45:35

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,657
Website

Re: local/intranet installation of an app does not run under IE and CHROME

Hello Walter,

The "problem" is that Firefox support cross origin request for local files, but Chrome nor Internet Explorer support this. Use local files also have some other problems like the local storage support: again Internet Explorer, for example, do not support local storage for local files. This is the reason why I decide to incorporate an HTTP server which App Builder uses for debug purposes and not simple load local files.

Really I don't know if Chrome and Internet Explorer can be configured to support XHR and other stuff also in local files (probably yes) but this is not the configuration by default, then probably it's not a good idea to distribute our apps to be running as local files.

Offline

Board footer

Powered by FluxBB


Copyright ©2018 DecSoft. All rights reserved.