#1 2016-05-24 12:01:37

EGovMetrics
Member
Registered: 2016-05-21
Posts: 39

Media Player with external videos

Hi,
Is it possible to use the Media Player with external videos on a web site ?

I am using the following script and it works properly.

NewArray "[VideoSources]"
ArrayPush "[VideoSources]" "app/files/a.mp4"
ArrayPush "[VideoSources]" "app/files/b.mp4"
ArrayPush "[VideoSources]" "app/files/c.mp4"

SetVar "[CurrentVideoIndex]" "0" "Number"
ArrayLength "[VideoSources]" "[TotalVideoSources]"

ArrayGetItem "[VideoSources]" "[CurrentVideoIndex]" "[CurrentVideoPath]"
MediaSetSource "MediaPlayer1" "" "[CurrentVideoPath]" "" ""

But can I use something like this ?

NewArray "[VideoSources]"
ArrayPush "[VideoSources]" "www.egovmetrics.com/AppMobilePlatform/Video/a.mp4"
ArrayPush "[VideoSources]" "www.egovmetrics.com/AppMobilePlatform/Video/b.mp4"
ArrayPush "[VideoSources]" "www.egovmetrics.com/AppMobilePlatform/Video/c.mp4"

SetVar "[CurrentVideoIndex]" "0" "Number"
ArrayLength "[VideoSources]" "[TotalVideoSources]"

ArrayGetItem "[VideoSources]" "[CurrentVideoIndex]" "[CurrentVideoPath]"
MediaSetSource "MediaPlayer1" "" "[CurrentVideoPath]" "" ""

It can be useful to handle the media content on a web site.

Thanks
Best
Joseph Caristena

Offline

#2 2016-05-24 12:05:45

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,661
Website

Re: Media Player with external videos

Hello,

There is no problem to use absolute URLs, in fact this is the recommended way, since we can't reproduce local files in platforms like Android. If you have problems using absolute URLs, try to start the URLs by the "http://www." instead "www.".

Offline

#3 2016-05-24 12:49:09

EGovMetrics
Member
Registered: 2016-05-21
Posts: 39

Re: Media Player with external videos

Hi,
I am using absolute URLs now.
But something strange is happening.
I hear the audio, but I do not see the video.
Why ?

Thanks
Best
Joseph Caristena

Offline

#4 2016-05-24 18:10:05

David
Admin
From: Alcobendas, Madrid, Spain
Registered: 2015-04-21
Posts: 1,661
Website

Re: Media Player with external videos

Hello,

Probably a "codec" related problem Joseph... for that reason we need to provide as much sources as possible: to let the browser to choose the more appropiate/suitable source to be reproduced. Honestly I don't think this is a problem of AB nor the media player control, but the video/browser itself... are you tried the video in various browsers? Are the results the same?

Offline

#5 2016-05-25 17:57:58

EGovMetrics
Member
Registered: 2016-05-21
Posts: 39

Re: Media Player with external videos

Hi,
You are right;)
Now it is working.

Thanks
Joseph Caristena

Offline

Board footer

Powered by FluxBB


Copyright ©2018 DecSoft. All rights reserved.